Cookies help us deliver our services. By using our services, you agree to our use of cookies.
Views

LMI Developer Documentation

From IHRIS Wiki

Revision as of 14:25, 9 December 2008 by Dcm (talk | contribs)
Jump to: navigation, search

To take advantage of further development of the system there are a few prerequisites for developers to have installed in order to work on the system. These can be found in the OpenMRS [Step-by-Step Installation for Developers] Document.

In addition to OpenMRS, we have developed a php library to add rapid development procedures for changing and updating the system if new indicators are needed in country. To make use of this library there are a few prerequisites to a standard linux distribution:

The smarty-gettext library is necessary to allow for multiple languages to be used in the system forms. To that end we made use of the smarty-gettext library which pulls in both the [Smarty PHP Library] and [gettext for PHP].

These may be very simple installation on some linux distributions. For example, on Ubuntu linux one may simply type

$sudo apt-get install smarty-gettext

and all of the necessary items should be installed on a trouble-free machine.

NOTE:

For Ubuntu 8.04 (Gutsy) you may need to issue the following command to fix a small problem with this library.

mv /usr/share/php/smarty/libs/plugins/block.t.php /usr/share/php/smarty/plugins/block.t.php